Jump to content

Search the Community

Showing results for tags 'kali'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OS
    • Linux
    • Windows
    • Virtualization
  • Coding
    • Php
    • Golang
    • JavaScript
    • Python|Ruby|Perl
    • C|C++|C#
    • DataBases
    • Lans
    • Other
    • Assembler
  • Underground
    • Security and its research
    • Hack Tools
    • Social engineering
    • Radio electronics / Phreaking
    • TV
    • Spam
    • For beginners
    • Cryptocurrency
  • Games
    • Strategy
    • Hacker Games
    • Books
    • Music
  • Other
    • News
    • Creative and Design
    • The Internet
    • SEO
    • Freebie
    • Training courses
    • Video Tutorials
    • Trading floor
    • Verstka
    • Talker
  • k0d.biz
    • Contests
    • Questions, comments and more
    • Site and forum news
    • Violations, complaints

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 7 results

  1. Установка и обновление vim до последней версии(Debian, Kali, Ubuntu) Случается что необходимо поставить vim последней версии, так как некоторые плагины идут лишь версией выше чем вашего vim'a. Есть 2 варианта: 1)Через репозиторий, но только для Ubuntu: Установка: sudo add-apt-repository ppa:jonathonf/vim sudo apt update sudo apt install vim Удаление: sudo rm /etc/apt/sources.list.d/jonathonf-ubuntu-vim-impish.list 2)Через git sudo apt install git git clone https://github.com/vim/vim.git cd vim sudo apt install libncurses-dev Курсивом выделены добавление интерпритатора python,lua и т.д., опционально: ./configure --with-features=huge --enable-multibyte --enable-gtk3-check --enable-rubyinterp=yes --with-python3-command=python3.7 --enable-python3interp=yes --enable-perlinterp=yes --enable-luainterp=yes --enable-cscope make sudo make install Если до этого при выполнении команды: which vim путь указывал на /usr/bin/vim, то теперь он ссылается на /usr/local/bin/vim, где соответсвенно лежит наш vim.
  2. Установка КриптоПро ЭЦП Browser plug-in в Kali Linux (Debian) В который раз сталкиваюсь с документацие от КриптоПро, в которой столько всего и всё в разноброс, хрен поймешь что с чем связано и как всё поставить. Начнём своё руководство. Заходим на страницу документации по установке КриптоПро ЭЦП Browser plug-in: https://docs.cryptopro.ru/cades/plugin/plugin-installation-unix Видим что нужно поставить КриптоПро версии 4.0 и выше: Идём на сайт CryptoPro: КриптоПро CSP - Загрузка файлов Качаем и ставим ПО. Замечу: оно даётся на 90 дней без лицензии, потом надо покупать лицензию. Купить лицензию тут: https://www.cryptopro.ru/order/?online=true После скачивания ПО вы получит .tar архив, распакуйте его и в нём вы получите такой набор данных: Устанавливаем ПО: sudo ./install.sh Видим что пакеты успешно поставлены. Переходим к пунту 2 на странице: https://docs.cryptopro.ru/cades/plugin/plugin-installation-unix Под какую разрядность скачать решать вам: Я скачал для 64 бита, получил .tar архив, его распаковываем и внутри получаем: Из полученного архива ставим 2 пакета cprocsp-pki-cades и cprocsp-pki-plugin: - cprocsp-pki-cades: sudo dpkg -i cprocsp-pki-cades-64_2.0.14071-1_amd64.deb 0x00000000 - показывает мол всё нормально. - cprocsp-pki-plugin: sudo dpkg -i cprocsp-pki-plugin-64_2.0.14071-1_amd64.deb У меня выдало ошибку: CryptoPro ECP browser plug-in requires rdr_gui_gtk package from CryptoPro CSP. Install it before installing this package. Где указано: требуется requires rdr_gui_gtk из пакетов CryptoPro CSP. Переходим в разархивированую папку с CryptoPro CSP, и ставим: sudo dpkg -i cprocsp-rdr-gui-gtk-64_5.0.11998-6_amd64.deb Переходим обратно в cades_linux_amd64 и пробуем ставить пакет еще раз: sudo dpkg -i cprocsp-pki-plugin-64_2.0.14071-1_amd64.deb Дальнейшие настройки различаются в зависимости от используемого браузера и выполняются в браузере. Показано здесь как с пункта №6: https://docs.cryptopro.ru/cades/plugin/plugin-installation-unix С установкой для работы закончено. А для тех кому надо подключить к коду продолжим: Активация объектов КриптоПро ЭЦП Browser plug-in Видим что нужно подключить: cadesplugin_api.js, но не указано откуда его брать. Взять его можно здесь: https://cryptopro.ru/products/cades/downloads Скачиваем его и получаем архив .zip с таким вложением: Теперь его переносим в свой проект и подключаем по инструкции: https://docs.cryptopro.ru/cades/plugin/plugin-activation?id=Активация-объектов-КриптоПро-ЭЦП-browser-plug-in
  3. Тестирование на проникновение с помощью Kali Linux 2.0 Информация в данной книге предназначена для ознакомления или тестирования на проникновение собственных сетей. Для тестирования сетей третьих лиц, получите письменное разрешение. "Тестирование на проникновение (жарг. Пентест) — метод оценки безопасности компьютерных систем или сетей средствами моделирования атаки злоумышленника." - WiKi Вся ответственность за реализацию действий, описанных в книге, лежит на вас. Помните, что за неправомерные действия предусмотрена ответственность, вплоть до уголовной. Скачать: 79ebfe10
  4. Kali Linux [ тестирование на проникновение и безопасность ] Эта книга предназначена для пентестеров, этических хакеров и профессионалов в области IT-безопасности, имеющих базовые знания об операционных системах Unix/Linux. Мы предполагаем, что читатель ознакомлен с концепцией информационной безопасности. Скачать: baf707bc
  5. Аудит безопасности информационных систем. Скабцов Н.В. В этой книге рассматриваются методы обхода систем безопасности сетевых сервисов и проникновения в открытые информационные системы. Информационная безопасность, как и многое в нашем мире, представляет собой медаль с двумя сторонами. С одной стороны, мы проводим аудит, ищем способы проникновения и даже применяем их на практике, а с другой — работаем над защитой. Тесты на проникновение являются частью нормального жизненного цикла любой ИТ-инфраструктуры, позволяя по-настоящему оценить возможные риски и выявить скрытые проблемы. Может ли взлом быть законным? Конечно, может! Но только в двух случаях — когда вы взламываете принадлежащие вам ИС или когда вы взламываете сеть организации, с которой у вас заключено письменное соглашение о проведении аудита или тестов на проникновение. Мы надеемся, что вы будете использовать информацию из данной книги только в целях законного взлома ИС. Пожалуйста, помните о неотвратимости наказания — любые незаконные действия влекут за собой административную или уголовную ответственность. Скачать: 35227cca
  6. Рад приветствовать. Случается такое, что при включении пк, что произошло после обновления системы, экран вместе привычного приветствия валится с моргающим курсором на тёмном окне и, и на этом всё, ни подсказок, ничего. Попытаемся решить и понять что не так: Имеется подопотный и рабочий зверь в виде Kali Linux. Обновления linux-header-5.8.0-kali1 и видео карта Nvidia GeForce GT 1030. При входе моргает курсор "_" на фоне черного экрана. Облазив кучу форумов результата не дало, везде сводится к одному: набору цитат: ты умник нахрена поставил kali начни с чего-нибудь полегче или запусти как Xinit, в общем толкового мало по даной теме. Приступим: Увидел черный экран с моргающим "_", жмём ctrl+alt+F2, тем самым переключаясь на свободный новый терминал, с мигающим курсоров в данный момент пыхтит с незапустившимися иксами, пока можно забыть про него. Переключившись на свободный терминал пытаемся узнать что произошло стартанув иксы с терминала: startx смотрим вывод и сразу смотрим лог по адресу cat /var/log/Xorg.0.log В итоге наблюдаем такую картину: [ 2023.742] (EE) No devices detected. [ 2023.742] (EE) Fatal server error: [ 2023.742] (EE) no screens found(EE) Много чего пробывал, создавал конфигурационый файл в /etc/X11 Xorg -configure что действительно создаёт конфигурационый файл в домашней папке root'a, который в итоге скопировал в /etc/X11. Всё же хоть конфигурационый файл встал на своё место, это не дало результата и иксы не запустились, но то что конфигурационый файл появился уже было не плохо, о чем свидетельствовала надпись при запуске команды startx Конфиг мол считан. Дальше скачал с сайта nvidia драйвера: https://ru.download.nvidia.com/XFree86/Linux-x86_64/450.66/NVIDIA-Linux-x86_64-450.66.run выставляем права на запуск: chmod +x NVIDIA-Linux-x86_64-450.66.run Стопорим всё активное с нашей графикой: /etc/init.d/gdm stop || /etc/init.d/gdm3 stop || /etc/init.d/kdm stop || /etc/init.d/lightdm stop Удаляем старые драйвера: apt purge nvidia-driver Начинаем ставить новые с сайта nvidia: ./NVIDIA-Linux-x86_64-450.66.run будет предложено поставить для 32x Если надо, то ставьте, мне вот нафиг не нужны. и вот оно сообщение, после которого я прозрел: Хоть тут и нет прямой инфы, но есть косвенная и сейчас обьясню: Решив глянуть по новому ядру лезем в: ls /usr/src Смотрим: Закрасил зелёным, так как я то уже поставил. и видим что нет нашего linux-headers-5.8.0-kali1, а лишь старое 5.7.0-kali3 Значит ставим! apt-get install linux-header-$(name -r|sed 's/[^-]*-[^-]*-//') дальше удалим всё что касается nvidia apt-get remove --purge 'nvidia-.*' Запустим установку драйвера еще разок ./NVIDIA-Linux-x86_64-450.66.run И ребутим: systemctl reboot И вот и всё! Запустилось!
×
×
  • Create New...