Jump to content

Search the Community

Showing results for tags 'js'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OS
    • Linux
    • Windows
  • Coding
    • Php
    • Golang
    • JavaScript
    • Python|Ruby
    • C|C++|C#
    • Other
    • DataBases
  • Underground
    • Security and its research
    • Hack Tools
    • Social engineering
    • Phreaking
    • TV
    • Spam
    • For beginners
  • Games
    • Generals
  • Other
    • News
    • Creative and Design
    • The Internet
    • SEO
    • Freebie
    • Training courses
    • Video Tutorials
    • Trading floor
    • Verstka
    • Talker
  • k0d.biz
    • Contests
    • Questions, comments and more
    • Site and forum news
    • Violations, complaints

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 4 results

  1. Как определить браузер на js? В JS есть такой обьект, под названием navigator. Наименование браузера: Как показано на странице описания обьекта navigator, наименование браузера можно выдернуть так: let sBrowser, sUsrAg = navigator.userAgent; if (sUsrAg.indexOf("Firefox") > -1) { sBrowser = "Mozilla Firefox"; //"Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" } else if (sUsrAg.indexOf("Opera") > -1) { sBrowser = "Opera"; } else if (sUsrAg.indexOf("Trident") > -1) { sBrowser = "Microsoft Intern
  2. Рассмотрим разделы зависимостей в package.json Полный список параметров package.json представлен здесь. Касательно зависимостей: dependencies : Зависимости, которые нужны для работы вашего проекта или компонента, для правильной работы. devDependencies : Зависимости используемые только при работе над вашим проектом. peerDependencies : Зависимости которые ваши нижестоящие пользователи должны убедиться, что они установили bundleDependencies : Вещи, которые понадобятся вашим нижестоящим пользователям, и не нужно будет устанавливать отдельно, потом
  3. При выполнении: npm install Получаем такое: Ошибка: Error: pngquant failed to build, make sure that libpng-dev is installed Перевод: pngquant не удалось собрать, убедитесь, что установлен libpng-dev Устанавливаем в системе, в которой выполняем установку: apt install -y build-essential libpng-dev build-essential libpng-dev Проверяем выполнение команды: npm install Успех. Исправно отработало. Есть warnings, но это совсем другая история,н и не так важно. Команда теперь выполняется.
  4. Встречается ошибка при сборке: pngquant pre-build test failed Решается: Leaving this here for anyone else trying to use Gatsby with WSL Debian After you have installed the pre-requisites, you will also need to install libpng-dev Pre-requisites: sudo apt install -y build-essential sudo apt install git
×
×
  • Create New...